Solid3dMassProperties Structure

This structure represents mass properties of a 3D solid. This instance is used together with 3dSolid.getMassProp().
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.DatabaseServicesSolid3dMassProperties

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct Solid3dMassProperties

The Solid3dMassProperties type exposes the following members.

Constructors
  Name Description
Public method Solid3dMassProperties Constructor for the Solid3dMassProperties class.
Top
Properties
  Name Description
Public property Centroid Property that represents the centroid of the solid.
Public property Extents Property that represents the extents (bounding box) of the solid.
Public property MomentsOfIntertia Property that represents the X, Y, and Z moments of inertia of the solid.
Public property PrincipalAxes Property that represents the principal axes of the solid.
Public property PrincipalMoments Property that represents the X, Y, Z principal moments of the solid.
Public property ProductsOfIntertia Property that represents the X, Y, Z products of inertia of the solid.
Public property RadiiOfGyration Property that represents the X, Y, Z radii of gyration of the solid.
Public property Volume Property that represents the volume of the solid.
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.