Solid3dCreateExtrudedSolid(Entity,
SubentityId, Vector3d, SweepOptions)
Method
|
Creates a solid by extruding a face in the
direction of the specified vector using a distance equal to the
length of the vector.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void CreateExtrudedSolid(
Entity sweepEntity,
SubentityId faceSubEntityId,
Vector3d directionVector,
SweepOptions sweepOptions
)
Public Overridable Sub CreateExtrudedSolid (
sweepEntity As Entity,
faceSubEntityId As SubentityId,
directionVector As Vector3d,
sweepOptions As SweepOptions
)
public:
virtual void CreateExtrudedSolid(
Entity^ sweepEntity,
SubentityId faceSubEntityId,
Vector3d directionVector,
SweepOptions^ sweepOptions
)
abstract CreateExtrudedSolid :
sweepEntity : Entity *
faceSubEntityId : SubentityId *
directionVector : Vector3d *
sweepOptions : SweepOptions -> unit
override CreateExtrudedSolid :
sweepEntity : Entity *
faceSubEntityId : SubentityId *
directionVector : Vector3d *
sweepOptions : SweepOptions -> unit
Parameters
- sweepEntity Entity
- [in] Swept entity.
- faceSubEntityId SubentityId
- [in] Object ID for the face that must be extruded.
- directionVector Vector3d
- [in] Vector determining the direction and length of
extrusion.
- sweepOptions SweepOptions
- [in] Set of sweeping options.
Remarks
This method is
implemented only for the Spatial modeler.
See Also