SurfaceTrimSurface Method
|
Trims a surface with the specified cutting
surfaces (curves). A surface can be trimmed by other surfaces or
curves. When curves are used, the actual trimming boundary is
formed by projecting the curves onto the surface, so the additional
information of projection directions needs to be provided.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public static void TrimSurface(
ObjectId blankSurfaceId,
ObjectIdCollection toolSurfaceIds,
ObjectIdCollection toolCurveIds,
Vector3dCollection projVectors,
Point3d pickPoint,
Vector3d viewVector,
bool bAutoExtend,
bool associativeEnabled
)
Public Shared Sub TrimSurface (
blankSurfaceId As ObjectId,
toolSurfaceIds As ObjectIdCollection,
toolCurveIds As ObjectIdCollection,
projVectors As Vector3dCollection,
pickPoint As Point3d,
viewVector As Vector3d,
bAutoExtend As Boolean,
associativeEnabled As Boolean
)
public:
static void TrimSurface(
ObjectId blankSurfaceId,
ObjectIdCollection^ toolSurfaceIds,
ObjectIdCollection^ toolCurveIds,
Vector3dCollection^ projVectors,
Point3d pickPoint,
Vector3d viewVector,
bool bAutoExtend,
bool associativeEnabled
)
static member TrimSurface :
blankSurfaceId : ObjectId *
toolSurfaceIds : ObjectIdCollection *
toolCurveIds : ObjectIdCollection *
projVectors : Vector3dCollection *
pickPoint : Point3d *
viewVector : Vector3d *
bAutoExtend : bool *
associativeEnabled : bool -> unit
Parameters
- blankSurfaceId ObjectId
- [in] Surface to be trimmed.
- toolSurfaceIds ObjectIdCollection
- [in] Array of the cutting entity's IDs. Bodies of the specified
entities are used to trim the specified surface.
- toolCurveIds ObjectIdCollection
- [in] Array of the cutting curve's IDs. The specified surface is
trimmed by projecting curves to it.
- projVectors Vector3dCollection
- [in] Array of projection directions for each cutting
curve.
- pickPoint Point3d
- [in] Pick point that specifies which area of the specified
surface must be trimmed.
- viewVector Vector3d
- [in] Vector representing the view direction for creating a ray
starting from the pick point.
- bAutoExtend Boolean
- [in] If true, then when a tool body consists of a single face
with analytic geometry, the underlying geometry is extended as much
as possible to make sure the surface is trimmed.
- associativeEnabled Boolean
- [in] Specifies whether the surface trimming operation is
associative.
See Also