GeometryPolyPolygon Method
|
Introduces multiple polygons to the
vectorization context. These polygons can be defined with various
properties including shape, opacity, outlines, etc. It can draw
multiple identical polygons and multiple different polygons at the
same time. If some of the parameters are not defined, they are
taken from the current SubEntityTraits properties.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public abstract bool PolyPolygon(
UInt32Collection numPolygonPositions,
Point3dCollection polygonPositions,
UInt32Collection numPolygonPoints,
Point3dCollection polygonPoints,
EntityColorCollection outlineColors,
LinetypeCollection outlineTypes,
EntityColorCollection fillColors,
TransparencyCollection fillOpacities
)
Public MustOverride Function PolyPolygon (
numPolygonPositions As UInt32Collection,
polygonPositions As Point3dCollection,
numPolygonPoints As UInt32Collection,
polygonPoints As Point3dCollection,
outlineColors As EntityColorCollection,
outlineTypes As LinetypeCollection,
fillColors As EntityColorCollection,
fillOpacities As TransparencyCollection
) As Boolean
public:
virtual bool PolyPolygon(
UInt32Collection^ numPolygonPositions,
Point3dCollection^ polygonPositions,
UInt32Collection^ numPolygonPoints,
Point3dCollection^ polygonPoints,
EntityColorCollection^ outlineColors,
LinetypeCollection^ outlineTypes,
EntityColorCollection^ fillColors,
TransparencyCollection^ fillOpacities
) abstract
abstract PolyPolygon :
numPolygonPositions : UInt32Collection *
polygonPositions : Point3dCollection *
numPolygonPoints : UInt32Collection *
polygonPoints : Point3dCollection *
outlineColors : EntityColorCollection *
outlineTypes : LinetypeCollection *
fillColors : EntityColorCollection *
fillOpacities : TransparencyCollection -> bool
Parameters
- numPolygonPositions UInt32Collection
- [in] Count array for each polygon index. Values of this array
represent the number of each kind of polygon.
- polygonPositions Point3dCollection
- [in] Array of polygon positions (offsets for each
polygon).
- numPolygonPoints UInt32Collection
- [in] Number of vertices for the polygons.
- polygonPoints Point3dCollection
- [in] Vertices of each polygon.
- outlineColors EntityColorCollection
- [in] Array of outline colors for polygon types. One
outlineColor per polygon index.
- outlineTypes LinetypeCollection
- [in] Array of outline types for polygon types. One outlineType
per polygon index.
- fillColors EntityColorCollection
- [in] Array of fill colors for polygon types. One fillColor per
polygon index.
- fillOpacities TransparencyCollection
- [in] Array of opacity objects for polygons. One fillOpacity per
polygon index.
Return Value
Boolean
true. This method also throws a corresponding exception if it
fails.
Remarks
Example API call
(where [] represents an array):
polyPolygon ([100, 7], [100 + 7 = 107 total positions], [4, 6], [4 + 6 = 10 total points], [outlinecolor0, outlinecolor1], [pattern0, pattern1], [fillcolor0, fillcolor1], [opacity0, opacity1]);
*100 identical 4-point polygons (polygon index 0) of outlinecolor0,
pattern0, fillcolor0, opacity0, and *7 identical 6-point polygons
(polygon index 1) of outlinecolor1, pattern1, fillcolor1,
opacity1.
See Also