UInt
|
The UInt32Collection type exposes the following members.
Name | Description | |
---|---|---|
![]() |
UInt32Collection | Default constructor for the UInt32Collection class. Creates an empty integer collection of 10 elements. |
![]() |
UInt32Collection(Int32) | Constructor for the UInt32Collection class. Creates an empty integer collection with the specified capacity. |
![]() |
UInt32Collection(UInt32) | Copy constructor for the UInt32Collection class. Creates an integer collection based on the passed array of unsigned integers. |
Name | Description | |
---|---|---|
![]() |
Capacity | Represents the number of elements that this collection can contain. |
![]() |
Count | Represents the number of elements that this collection currently stores. |
![]() |
IsFixedSize | Property that indicates whether this collection has a fixed size. |
![]() |
IsReadOnly | Property that indicates whether this collection is read-only. |
![]() |
IsSynchronized | Property that indicates whether access to this collection is thread-safe. |
![]() |
Item | Property that represents an item from the collection at the specified index. |
![]() |
SyncRoot | Property that represents an object that can be used to synchronize access to this collection. |
Name | Description | |
---|---|---|
![]() |
Add | Adds a value to the end of this integer collection. This method grows the collection capacity if necessary. |
![]() |
AddRange | Adds a range of unsigned integer values to the end of this integer collection. This method grows the collection capacity if necessary. |
![]() |
Clear | Clears this integer collection. |
![]() |
Contains | Checks whether this integer collection contains the specified value. |
![]() |
CopyTo | Copies the specified array to this integer collection at the specified index. |
![]() |
Equals | Determines whether the specified object is equal to the current
object. (Inherited from Object) |
![]() |
Finalize | Allows an object to try to free resources and perform other
cleanup operations before it is reclaimed by garbage
collection. (Inherited from Object) |
![]() |
GetEnumerator | Returns the enumerator for this collection. |
![]() |
GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
IEnumerable_GetEnumerator | Returns the enumerator for this collection. |
![]() |
IndexOf | Returns an index from the collection of the specified value. |
![]() |
Insert | Inserts the specified value to the collection at the provided index. |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
Remove | Removes the specified value from the collection. |
![]() |
RemoveAt | Removes a value from the collection at the specified index. |
![]() |
ToArray | Returns a handle to an array that represents this unsigned integer collection. |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
![]() |
TrimToSize | Sets the capacity to the actual number of elements in this unsigned integer collection. |
Name | Description | |
---|---|---|
![]() ![]() |
DefaultSize | Size of the default unsigned integer collection. |
© Bricsys NV. All rights reserved. |