Linetype
|
The LinetypeCollection type exposes the following members.
Name | Description | |
---|---|---|
![]() |
LinetypeCollection | Default constructor for the LinetypeCollection class. Creates an empty collection of linetypes. |
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
Count | Property that represents the number of elements that this collection currently stores. |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
IsFixedSize | Property that indicates whether this collection has a fixed size. |
![]() |
IsReadOnly | Property that indicates whether this collection is read-only. |
![]() |
Item | Property that represents an item at the specified index in the collection. |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
Name | Description | |
---|---|---|
![]() |
Add | Adds a linetype to the collection. |
![]() |
Clear | Clears this collection of linetypes. |
![]() |
Contains | Checks whether this collection contains a linetype that matches the specified linetype. |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
GetEnumerator | Returns the enumerator for this linetype collection. |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
IndexOf | Returns the index of the linetype that matches the specified linetype in the collection. |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
Insert | Inserts the specified linetype to the collection at the provided index. |
![]() |
Remove | Removes a linetype in the collection that matches the specified linetype. |
![]() |
RemoveAt | Removes a linetype from the collection at the specified index. |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
© Bricsys NV. All rights reserved. |