PlanarEntityClosestPointToLinearEntity(LinearEntity3d, Tolerance) Method

Calculates the point on this planar entity that is closest to the specified line and the point on the specified line that is closest to this planar entity.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public Point3d[] ClosestPointToLinearEntity(
        LinearEntity3d line,
        Tolerance tolerance
)

Parameters

line  LinearEntity3d
[in] A line to which a closest point is calculated.
tolerance  Tolerance
[in] Geometric tolerance.

Return Value

Point3d
Array with two points. The first point is the closest point on the specified line, and the second point is the closest point on this planar entity.
See Also

©  Bricsys NV. All rights reserved.