GripOverruleMoveGripPointsAt(Entity, GripDataCollection, Vector3d, MoveGripPointsFlags) Method

Overrules the OdDbEntity::subMoveGripPointsAt() C++ method and calls it in the default implementation.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public virtual void MoveGripPointsAt(
        Entity entity,
        GripDataCollection grips,
        Vector3d offset,
        MoveGripPointsFlags bitFlags
)

Parameters

entity  Entity
[in] Entity that this overrule applies to.
grips  GripDataCollection
[in] A collection containing the indices corresponding to grip points obtained from the getGripPoints() method that indicates which grip points are now "hot".
offset  Vector3d
[in] A vector that indicates the direction and magnitude to which the grip points have been translated.
bitFlags  MoveGripPointsFlags
[in] Mask of one or more flags specified by the MoveGripPointsFlags enumeration.
See Also

©  Bricsys NV. All rights reserved.