CompoundObjectId(ObjectId,
ObjectIdCollection, Database) Constructor
|
Constructor for the CompoundObjectId class.
Creates a compound object ID from the passed object ID and a path
of BlockReferences.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public CompoundObjectId(
ObjectId id,
ObjectIdCollection path,
Database hostDatabase
)
Public Sub New (
id As ObjectId,
path As ObjectIdCollection,
hostDatabase As Database
)
public:
CompoundObjectId(
ObjectId id,
ObjectIdCollection^ path,
Database^ hostDatabase
)
new :
id : ObjectId *
path : ObjectIdCollection *
hostDatabase : Database -> CompoundObjectId
Parameters
- id ObjectId
- [in] Object ID.
- path ObjectIdCollection
- [in] The path of BlockRefrences that lead to the referenced
object.
- hostDatabase Database
- [in] The host database.
See Also