EntityGetGripPointsAtSubentityPath
Method
|
Gets the grip points and supporting
information about the grips for a subentity.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual bool GetGripPointsAtSubentityPath(
FullSubentityPath subPath,
GripDataCollection grips,
double curViewUnitSize,
int gripSize,
Vector3d curViewDir,
GetGripPointsFlags bitFlags
)
Public Overridable Function GetGripPointsAtSubentityPath (
subPath As FullSubentityPath,
grips As GripDataCollection,
curViewUnitSize As Double,
gripSize As Integer,
curViewDir As Vector3d,
bitFlags As GetGripPointsFlags
) As Boolean
public:
virtual bool GetGripPointsAtSubentityPath(
FullSubentityPath subPath,
GripDataCollection^ grips,
double curViewUnitSize,
int gripSize,
Vector3d curViewDir,
GetGripPointsFlags bitFlags
)
abstract GetGripPointsAtSubentityPath :
subPath : FullSubentityPath *
grips : GripDataCollection *
curViewUnitSize : float *
gripSize : int *
curViewDir : Vector3d *
bitFlags : GetGripPointsFlags -> bool
override GetGripPointsAtSubentityPath :
subPath : FullSubentityPath *
grips : GripDataCollection *
curViewUnitSize : float *
gripSize : int *
curViewDir : Vector3d *
bitFlags : GetGripPointsFlags -> bool
Parameters
- subPath FullSubentityPath
- [in] Full path to the subentity.
- grips GripDataCollection
- [in/out] Receives a collection of pointers of GripData
objects.
- curViewUnitSize Double
- [in] The size (in pixels) of one drawing unit in the current
viewport.
- gripSize Int32
- [in] The current grip size (in pixels).
- curViewDir Vector3d
- [in] The view direction in the current viewport.
- bitFlags GetGripPointsFlags
- [in] The bitmap of one or more flags specified by the
GetGripPointsFlags enumeration.
Return Value
Boolean
true if the method is implemented,
false otherwise.
See Also