ObjectIterator Class

This class defines bidirectional iterator objects that traverse entities contained in complex entities.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesObjectIterator

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class ObjectIterator : RXObject, 
        IEnumerator

The ObjectIterator type exposes the following members.

Properties
  Name Description
Public property Current Property that represents a currently iterated object.
Top
Methods
  Name Description
Public method MoveNext Moves the iterator to the next ObjectId.
Public method Reset Sets this iterator to reference the entity that it would normally return first.
Top
Remarks
This class cannot be directly instantiated; it must be instantiated with the iterator creation methods of the class to be iterated through.
See Also

©  Bricsys NV. All rights reserved.