LinearEntity3dProjectedIntersectWith(LinearEntity3d,
Vector3d, Tolerance) Method
|
Calculates the projected intersection of the
specified line with this linear entity according to a
tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point3d[] ProjectedIntersectWith(
LinearEntity3d line,
Vector3d projectionDirection,
Tolerance tolerance
)
Public Function ProjectedIntersectWith (
line As LinearEntity3d,
projectionDirection As Vector3d,
tolerance As Tolerance
) As Point3d()
public:
array<Point3d>^ ProjectedIntersectWith(
LinearEntity3d^ line,
Vector3d projectionDirection,
Tolerance tolerance
)
member ProjectedIntersectWith :
line : LinearEntity3d *
projectionDirection : Vector3d *
tolerance : Tolerance -> Point3d[]
Parameters
- line LinearEntity3d
- [in] 3D projected linear entity with which the intersection is
computed.
- projectionDirection Vector3d
- [in] Projection direction.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Point3d
Array with intersection points. Indices: * 0 - Intersection point
on this line * 1 - Intersection point on the passed line
See Also