Solid3dCreateRevolvedSolid(Entity,
Point3d, Vector3d, Double, Double,
RevolveOptions) Method
|
Creates a solid by revolving a specified
curve, region, or planar surface around the specified axis of
revolution.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void CreateRevolvedSolid(
Entity profileEntity,
Point3d axisPoint,
Vector3d axisDir,
double angleOfRevolution,
double startAngle,
RevolveOptions revolveOptions
)
Public Overridable Sub CreateRevolvedSolid (
profileEntity As Entity,
axisPoint As Point3d,
axisDir As Vector3d,
angleOfRevolution As Double,
startAngle As Double,
revolveOptions As RevolveOptions
)
public:
virtual void CreateRevolvedSolid(
Entity^ profileEntity,
Point3d axisPoint,
Vector3d axisDir,
double angleOfRevolution,
double startAngle,
RevolveOptions^ revolveOptions
)
abstract CreateRevolvedSolid :
profileEntity : Entity *
axisPoint : Point3d *
axisDir : Vector3d *
angleOfRevolution : float *
startAngle : float *
revolveOptions : RevolveOptions -> unit
override CreateRevolvedSolid :
profileEntity : Entity *
axisPoint : Point3d *
axisDir : Vector3d *
angleOfRevolution : float *
startAngle : float *
revolveOptions : RevolveOptions -> unit
Parameters
- profileEntity Entity
- [in] Planar curve, region, or planar surface to revolve.
- axisPoint Point3d
- [in] Point on the axis of revolution.
- axisDir Vector3d
- [in] Direction of the revolution axis.
- angleOfRevolution Double
- [in] Revolution angle in radians.
- startAngle Double
- [in] Start angle of rotation. If 0, rotation starts from the
current position of the revolved entity.
- revolveOptions RevolveOptions
- [in] Revolve options.
Remarks
Axis of revolution
is defined by a point (axisPoint) and vector (axisDir). The
profileEntity is revolved according to the start angle and revolve
angle counter-clockwise about the axisDir vector. This method is
implemented only for the Spatial modeler.
See Also