MlineStyleElement Structure

This class stores information about color, offset, and linetype ID values used for MlineStyle objects.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.DatabaseServicesMlineStyleElement

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct MlineStyleElement

The MlineStyleElement type exposes the following members.

Constructors
  Name Description
Public method MlineStyleElement Constructor for the MlineStyleElement class. Creates a style element with the specified element offset, color and object ID of a linetype.
Top
Properties
  Name Description
Public property Color Property that represents the color of the style element.
Public property LinetypeId Property that represents the object ID of a linetype used as part of the style element.
Public property Offset Property that represents the offset of the style element.
Top
Methods
  Name Description
Public method ToString Returns a string representation of this object.
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider) Returns a string representation of this object depending on the UI culture defined by the provider.
Top
See Also

©  Bricsys NV. All rights reserved.