CurveSetFromGeCurve(Curve3d,
Vector3d, Tolerance) Method
|
Sets parameters of this curve identical to the
passed OdGeCurve3d curve (wrapped by the Curve3d class). This curve
lies on a plane with a normal vector perpendicular to the
plane.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetFromGeCurve(
Curve3d geCurve,
Vector3d vec,
Tolerance tolerance
)
Public Sub SetFromGeCurve (
geCurve As Curve3d,
vec As Vector3d,
tolerance As Tolerance
)
public:
void SetFromGeCurve(
Curve3d^ geCurve,
Vector3d vec,
Tolerance tolerance
)
member SetFromGeCurve :
geCurve : Curve3d *
vec : Vector3d *
tolerance : Tolerance -> unit
Parameters
- geCurve Curve3d
- [in] OdGe curve from which to set parameters.
- vec Vector3d
- [in] Normal to the plane where the curve lies.
- tolerance Tolerance
- [in] Geometric tolerance.
See Also