MTextFragment Class

This class describes a fragment of text created by the MText.explodeFragments() method.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesMTextFragment

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class MTextFragment : DisposableWrapper

The MTextFragment type exposes the following members.

Properties
  Name Description
Public property BigFont Property that represents the SHX bigfont name.
Public property Bold Property that indicates whether the text is bold.
Public property CapsHeight Property that represents text height.
Public property Color Property that represents text color.
Public property Direction Property that represents text flow direction vector.
Public property Extents Property that represents text extents in OCS.
Public property Italic Property that indicates whether the text is italic.
Public property LineBreak Property that indicates whether the text fragment is followed by a line break.
Public property Location Property that represents the insertion point of the text.
Public property NewParagraph Property that indicates the whether text fragment starts a new paragraph.
Public property Normal Property that represents the normal vector to the plane that contains the text fragment.
Public property ObliqueAngle Property that represents the oblique angle of the text.
Public property Overlined Property that indicates whether the text is overlined.
Public property ShxFont Property that represents the SHX font name.
Public property StackBottom Property that indicates whether this text is the bottom part of stacked text.
Public property StackTop Property that indicates whether this text is the top part of stacked text.
Public property Text Property that represents the text string.
Public property TrackingFactor Property that represents the text tracking factor.
Public property TrueTypeFont Property that represents the TrueType font name.
Public property Underlined Property that indicates whether the text is underlined.
Public property WidthFactor Property that represents the text width factor.
Top
Methods
  Name Description
Public method GetOverLinePoints Returns overline endpoints.
Public method GetUnderLinePoints Returns underline endpoints.
Top
See Also

©  Bricsys NV. All rights reserved.