DynamicBlockReferenceProperty Class

This class is a utility class referencing properties of dynamic blocks.
Inheritance Hierarchy
SystemObject
  Teigha.DatabaseServicesDynamicBlockReferenceProperty

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class DynamicBlockReferenceProperty

The DynamicBlockReferenceProperty type exposes the following members.

Properties
  Name Description
Public property BlockId Property that represents the object ID of the block reference.
Public property Description Property that represents the description of this property.
Public property PropertyName Property that represents the name of this property. All property names in a given block reference are unique.
Public property PropertyTypeCode Property that represents the type of the property value.
Public property ReadOnly Property that indicates whether this property is read-only.
Public property Show Property that indicates whether this property is shown in the Property Palette.
Public property UnitsType Property that represents units for this property.
Public property Value Property that represents the current value of the property on the dynamic block reference.
Public property VisibleInCurrentVisibilityState Property that indicates whether this property is visible in the current visibility state.
Top
Methods
  Name Description
Public method GetAllowedValues Returns an array of allowed values for this property.
Top
See Also

©  Bricsys NV. All rights reserved.