DataLinkManager Class

This class manages the data links in a database.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesDataLinkManager

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class DataLinkManager : RXObject

The DataLinkManager type exposes the following members.

Properties
  Name Description
Public property DataLinkCount Property that represents the number of data links in this manager.
Top
Methods
  Name Description
Public method AddDataLink Adds the specified data link object to this manager.
Public method GetDataLink Returns a collection of object identifiers of data links.
Public method GetDataLink(String) Returns the object ID for a data link with the specified name.
Public method RemoveDataLink(ObjectId) Removes a data link that has the specified object identifier of the data link.
Public method RemoveDataLink(String) Removes a data link with the specified data link name.
Public method Update(UpdateDirection, UpdateOption) Updates the data for all data links in this data link manager.
Public method Update(ObjectIdCollection, UpdateDirection, UpdateOption) Updates the data for the specified data links in this data link manager.
Top
See Also

©  Bricsys NV. All rights reserved.