ObjectOverruleWblockClone
Method
|
Calls the corresponding
OdDbObjectOverrule::wblockClone() method.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual DBObject WblockClone(
DBObject dbObject,
RXObject ownerObject,
IdMapping idMap,
bool isPrimary
)
Public Overridable Function WblockClone (
dbObject As DBObject,
ownerObject As RXObject,
idMap As IdMapping,
isPrimary As Boolean
) As DBObject
public:
virtual DBObject^ WblockClone(
DBObject^ dbObject,
RXObject^ ownerObject,
IdMapping^ idMap,
bool isPrimary
)
abstract WblockClone :
dbObject : DBObject *
ownerObject : RXObject *
idMap : IdMapping *
isPrimary : bool -> DBObject
override WblockClone :
dbObject : DBObject *
ownerObject : RXObject *
idMap : IdMapping *
isPrimary : bool -> DBObject
Parameters
- dbObject DBObject
- [in] Database object to which the overrule is applied.
- ownerObject RXObject
- [in] Database object to which the clones should be
appended.
- idMap IdMapping
- [in] A current object ID map.
- isPrimary Boolean
- [in] Flag that indicates whether this object is primary or
owned.
Return Value
DBObject
Cloned database object.
See Also