WallCutLineAnchorCollection Class

This class represents a collection of WallCutLineAnchor objects.
Inheritance Hierarchy
SystemObject
  Teigha.Aec.Arch.DatabaseServicesWallCutLineAnchorCollection

Namespace: Teigha.Aec.Arch.DatabaseServices
Assembly: TA_MgdArch (in TA_MgdArch.dll) Version: 0.0.0.0
Syntax
public sealed class WallCutLineAnchorCollection : IList

The WallCutLineAnchorCollection type exposes the following members.

Constructors
  Name Description
Public method WallCutLineAnchorCollection Default constructor for the WallCutLineAnchorCollection class.
Top
Properties
  Name Description
Public property Count Represents the number of elements that this collection currently stores.
Public property Item Property that represents a WallCutLineAnchor object at the specified index.
Top
Methods
  Name Description
Public method Add Adds the specified WallCutLineAnchor object as the next object in the collection.
Public method Clear Erases all items from the collection.
Public method Contains Checks whether this collection contains the specified element.
Public method CopyTo Copies this collection to the specified array at the specified index.
Public method GetEnumerator Returns the enumerator for this collection.
Public method IndexOf Returns the index of the WallCutLineAnchor object in the collection that matches the specified object.
Public method Insert Inserts the specified WallCutLineAnchor object to the collection at the provided index.
Public method Remove Removes a WallCutLine object that matches the specified object from the collection.
Public method RemoveAt Removes a WallCutLineAnchor object from the collection at the specified index.
Top
See Also

©  Bricsys NV. All rights reserved.