DatabaseSummaryInfoBuilder Class

This class is required to build a DatabaseSummaryInfo object which stores a set of strings providing additional information about a .dwg file.
Inheritance Hierarchy
SystemObject
  Teigha.DatabaseServicesDatabaseSummaryInfoBuilder

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class DatabaseSummaryInfoBuilder

The DatabaseSummaryInfoBuilder type exposes the following members.

Constructors
  Name Description
Public method DatabaseSummaryInfoBuilder Default constructor for the DatabaseSummaryInfoBuilder class.
Public method DatabaseSummaryInfoBuilder(DatabaseSummaryInfo) Constructor for the DatabaseSummaryInfoBuilder class.
Top
Properties
  Name Description
Public property Author  
Public property Comments  
Public property CustomProperties Obsolete.
Property for accessing custom property values. This property is obsolete; use the CustomPropertyTable property instead.
Public property CustomPropertyTable Property for accessing a custom properties table dictionary.
Public property HyperlinkBase  
Public property Keywords  
Public property LastSavedBy  
Public property RevisionNumber  
Public property Subject  
Public property Title  
Top
Methods
  Name Description
Public method ToDatabaseSummaryInfo Returns an underlying DatabaseSummaryInfo object that stores the values specified for this object.
Top
See Also

©  Bricsys NV. All rights reserved.