GripOverruleMoveGripPointsAt(Entity,
IntegerCollection, Vector3d) Method
|
Overrules the
OdDbEntity::subMoveGripPointsAt() C++ method and calls it in the
default implementation.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void MoveGripPointsAt(
Entity entity,
IntegerCollection indices,
Vector3d offset
)
Public Overridable Sub MoveGripPointsAt (
entity As Entity,
indices As IntegerCollection,
offset As Vector3d
)
public:
virtual void MoveGripPointsAt(
Entity^ entity,
IntegerCollection^ indices,
Vector3d offset
)
abstract MoveGripPointsAt :
entity : Entity *
indices : IntegerCollection *
offset : Vector3d -> unit
override MoveGripPointsAt :
entity : Entity *
indices : IntegerCollection *
offset : Vector3d -> unit
Parameters
- entity Entity
- [in] Entity that this overrule applies to.
- indices IntegerCollection
- [in] A collection containing the indices corresponding to grip
points obtained from the getGripPoints() method that indicates
which grip points are now "hot".
- offset Vector3d
- [in] A vector that indicates the direction and magnitude to
which the grip points have been translated.
See Also