TableSetGridProperty(CellRange,
GridLineType, GridPropertyParameter)
Method
|
Sets the grid line property of the cell, row
or column.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void SetGridProperty(
CellRange rangeIn,
GridLineType gridLineTypes,
GridPropertyParameter gridProp
)
Public Overridable Sub SetGridProperty (
rangeIn As CellRange,
gridLineTypes As GridLineType,
gridProp As GridPropertyParameter
)
public:
virtual void SetGridProperty(
CellRange^ rangeIn,
GridLineType gridLineTypes,
GridPropertyParameter gridProp
)
abstract SetGridProperty :
rangeIn : CellRange *
gridLineTypes : GridLineType *
gridProp : GridPropertyParameter -> unit
override SetGridProperty :
rangeIn : CellRange *
gridLineTypes : GridLineType *
gridProp : GridPropertyParameter -> unit
Parameters
- rangeIn CellRange
- [in] Row index.
- gridLineTypes GridLineType
- [in] Grid linetypes.
- gridProp GridPropertyParameter
- [in] Grid property.
Remarks
The gridlineType
parameter must have one of the following values:
NameValueDescriptionHorizontalTop 0x01 Top or
bottom horizontal table's grid line, depending on the flow
direction of the table rows (down or up). HorizontalInside 0x02 All
horizontal grid lines, excluding the bottom and top lines.
HorizontalBottom 0x04 Bottom or top horizontal table's grid line,
depending on the flow direction of the table rows (down or up).
VerticalLeft 0x08 The grid line at the left of the table.
VerticalInside 0x10 All vertical grid lines, excluding the left and
right lines. VerticalRight 0x20 The grid line at the right of the
table.
See Also