TableHitTest Method

Performs a hit test for the specified point and viewing direction in this table entity. Returns the row index and the column index of the cell, hit by the ray in the output arguments.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public virtual TableHitTestInfo HitTest(
        Point3d point,
        Vector3d viewVector
)

Parameters

point  Point3d
[in] 3D picking point in WCS.
viewVector  Vector3d
[in] 3D vector in WCF that specifies the view direction for the hit test.

Return Value

TableHitTestInfo
TableHitTestInfo instance that contains information about performed hit test.
See Also

©  Bricsys NV. All rights reserved.