GripOverruleMoveStretchPointsAt
Method
|
Overrules the
OdDbEntity::subMoveStretchPointsAt() C++ method and calls it in the
default implementation.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void MoveStretchPointsAt(
Entity entity,
IntegerCollection indices,
Vector3d offset
)
Public Overridable Sub MoveStretchPointsAt (
entity As Entity,
indices As IntegerCollection,
offset As Vector3d
)
public:
virtual void MoveStretchPointsAt(
Entity^ entity,
IntegerCollection^ indices,
Vector3d offset
)
abstract MoveStretchPointsAt :
entity : Entity *
indices : IntegerCollection *
offset : Vector3d -> unit
override MoveStretchPointsAt :
entity : Entity *
indices : IntegerCollection *
offset : Vector3d -> unit
Parameters
- entity Entity
- [in] Entity that this overrule applies to.
- indices IntegerCollection
- [in] An array containing the indices that indicate which
stretch points are being translated.
- offset Vector3d
- [in] Vector (in WCS coordinates) indicating the direction and
magnitude that the stretch points have been translated.
See Also