Class AcadDim3PointAngular
Member of BricscadDb
A dimension measuring the angular distance between three points. To create a 3-point angular dimension, use the AddDim3PointAngular method. To access the Dim3PointAngular object, use the following methods and properties:
Methods | Properties |
---|---|
ArrayPolar | AngleFormat |
ArrayRectangular | AngleVertex |
Copy | Application |
Delete | Arrowhead1Block |
GetBoundingBox | Arrowhead1Type |
GetExtensionDictionary | Arrowhead2Block |
GetXData | Arrowhead2Type |
Highlight | ArrowheadSize |
IntersectWith | DecimalSeparator |
Mirror | DimensionLineColor |
Mirror3D | DimLine1Suppress |
Move | DimLine2Suppress |
Rotate | DimLineInside |
Rotate3D | Document |
ScaleEntity | ExtensionLineColor |
SetXData | ExtensionLineExtend |
TransformBy | ExtensionLineOffset |
Update | ExtLine1EndPoint |
ExtLine1StartPoint | |
ExtLine1Suppress | |
ExtLine2EndPoint | |
ExtLine2StartPoint | |
ExtLine2Suppress | |
Fit | |
ForceLineInside | |
Handle | |
HasExtensionDictionary | |
HorizontalTextPosition | |
Hyperlinks | |
Layer | |
Linetype | |
LinetypeScale | |
Lineweight | |
Measurement | |
Normal | |
ObjectID | |
ObjectName | |
OwnerID | |
PlotStyleName | |
Rotation | |
ScaleFactor | |
StyleName | |
SuppressLeadingZeroes | |
SuppressTrailingZeroes | |
TextColor | |
TextFill * | |
TextFillColor * | |
TextGap | |
TextHeight | |
TextInside | |
TextInsideAlign | |
TextMovement | |
TextOutsideAlign | |
TextOverride | |
TextPosition | |
TextPrecision | |
TextPrefix | |
TextRotation | |
TextString | |
TextStyle | |
TextSuffix | |
ToleranceDisplay | |
ToleranceHeightScale | |
ToleranceJustification | |
ToleranceLowerLimit | |
TolerancePrecision | |
ToleranceSuppressLeadingZeroes | |
ToleranceSuppressTrailingZeroes | |
ToleranceSuppressZeroFeet | |
ToleranceSuppressZeroInches | |
ToleranceUpperLimit | |
TrueColor | |
VerticalTextPosition | |
Visible |
© Bricsys NV. All rights reserved. |