Class AcadDimAngular
Member of BricscadDb
A dimension measuring the angular distance between two lines or between the angle of a circular arc. To create an angular dimension, use the AddDimAngular method. To access the Dim3PointAngular object, use the following methods and properties:
Methods | Properties |
---|---|
ArrayPolar | AngleVertex |
ArrayRectangular | Application |
Copy | Arrowhead1Block |
Delete | Arrowhead1Type |
GetBoundingBox | Arrowhead2Block |
GetExtensionDictionary | Arrowhead2Type |
GetXData | ArrowheadSize |
Highlight | DecimalSeparator |
IntersectWith | DimensionLineColor |
Mirror | DimLine1Suppress |
Mirror3D | DimLine2Suppress |
Move | DimLineInside |
Rotate | Document |
Rotate3D | ExtensionLineColor |
ScaleEntity | ExtensionLineExtend |
SetXData | ExtensionLineOffset |
TransformBy | ExtLine1EndPoint |
Update | ExtLine1StartPoint |
ExtLine1Suppress | |
ExtLine2EndPoint | |
ExtLine2StartPoint | |
ExtLine2Suppress | |
Fit | |
ForceLineInside | |
Handle | |
HasExtensionDictionary | |
HorizontalTextPosition | |
Hyperlinks | |
Layer | |
Linetype | |
LinetypeScale | |
Lineweight | |
Measurement | |
Normal | |
ObjectID | |
ObjectName | |
OwnerID | |
PlotStyleName | |
Rotation | |
ScaleFactor | |
StyleName | |
SuppressLeadingZeroes | |
SuppressTrailingZeroes | |
TextColor | |
TextFill * | |
TextFillColor * | |
TextGap | |
TextHeight | |
TextInside | |
TextInsideAlign | |
TextMovement | |
TextOutsideAlign | |
TextOverride | |
TextPosition | |
TextPrecision | |
TextPrefix | |
TextRotation | |
TextString | |
TextStyle | |
TextSuffix | |
ToleranceDisplay | |
ToleranceHeightScale | |
ToleranceJustification | |
ToleranceLowerLimit | |
TolerancePrecision | |
ToleranceSuppressLeadingZeroes | |
ToleranceSuppressTrailingZeroes | |
ToleranceSuppressZeroFeet | |
ToleranceSuppressZeroInches | |
ToleranceUpperLimit | |
TrueColor | |
VerticalTextPosition | |
Visible |
© Bricsys NV. All rights reserved. |