Class AcadDimDiametric
Member of BricscadDb
A dimension measuring the diameter of a circle. To create a diametric dimension, use the AddDimDiametric method. To access the DimDiametric object, use the following methods and properties:
Methods | Properties |
---|---|
ArrayPolar | AltRoundDistance |
ArrayRectangular | AltSuppressLeadingZeroes |
Copy | AltSuppressTrailingZeroes |
Delete | AltSuppressZeroFeet |
GetBoundingBox | AltSuppressZeroInches |
GetExtensionDictionary | AltTextPrefix |
GetXData | AltTextSuffix |
Highlight | AltTolerancePrecision |
IntersectWith | AltToleranceSuppressLeadingZeroes |
Mirror | AltToleranceSuppressTrailingZeroes |
Mirror3D | AltToleranceSuppressZeroFeet |
Move | AltToleranceSuppressZeroInches |
Rotate | AltUnits |
Rotate3D | AltUnitsFormat |
ScaleEntity | AltUnitsPrecision |
SetXData | AltUnitsScale |
TransformBy | Application |
Update | Arrowhead1Block |
Arrowhead1Type | |
Arrowhead2Block | |
Arrowhead2Type | |
ArrowheadSize | |
CenterMarkSize | |
CenterType | |
DecimalSeparator | |
DimensionLineColor | |
DimLine1Suppress | |
DimLine2Suppress | |
Document | |
ExtensionLineOffset | |
Fit | |
ForceLineInside | |
FractionFormat | |
Handle | |
HasExtensionDictionary | |
HorizontalTextPosition | |
Hyperlinks | |
Layer | |
LeaderLength | |
LinearScaleFactor | |
Linetype | |
LinetypeScale | |
Lineweight | |
Measurement | |
Normal | |
ObjectID | |
ObjectName | |
OwnerID | |
PlotStyleName | |
PrimaryUnitsPrecision | |
Rotation | |
RoundDistance | |
ScaleFactor | |
StyleName | |
SuppressLeadingZeroes | |
SuppressTrailingZeroes | |
SuppressZeroFeet | |
SuppressZeroInches | |
TextColor | |
TextGap | |
TextHeight | |
TextInside | |
TextInsideAlign | |
TextMovement | |
TextOutsideAlign | |
TextOverride | |
TextPosition | |
TextPrecision | |
TextPrefix | |
TextRotation | |
TextString | |
TextStyle | |
TextSuffix | |
ToleranceDisplay | |
ToleranceHeightScale | |
ToleranceJustification | |
ToleranceLowerLimit | |
TolerancePrecision | |
ToleranceSuppressLeadingZeroes | |
ToleranceSuppressTrailingZeroes | |
ToleranceSuppressZeroFeet | |
ToleranceSuppressZeroInches | |
ToleranceUpperLimit | |
TrueColor | |
UnitsFormat | |
VerticalTextPosition | |
Visible |
© Bricsys NV. All rights reserved. |