Dimension object

Class AcadDimension

Member of BricscadDb

The Dimension object represents a dimension in a drawing. Dimensions may be angular, linear, radial, or one of several other types. To create a dimension, use one of the AddDimXXX methods. To query or edit an existing dimension, use the following methods and properties:


Methods Properties
ArrayPolar Application
ArrayRectangular DecimalSeparator
Copy Document
Delete Handle
GetBoundingBox HasExtensionDictionary
GetExtensionDictionary Hyperlinks
GetXData Layer
Highlight Linetype
IntersectWith LinetypeScale
Mirror Lineweight
Mirror3D Material *
Move Normal
Rotate ObjectID
Rotate3D ObjectName
ScaleEntity OwnerID
SetXData PlotStyleName
TransformBy Rotation
Update ScaleFactor
  StyleName
  SuppressLeadingZeroes
  SuppressTrailingZeroes
  TextColor
  TextFill *
  TextGap
  TextHeight
  TextMovement
  TextOverride
  TextPosition
  TextPrefix
  TextRotation
  TextString
  TextStyle
  TextSuffix
  ToleranceDisplay
  ToleranceHeightScale
  ToleranceJustification
  TolearanceLowerLimit
  TolerancePrecision
  ToleranceSuppressLeadingZeroes
  ToleranceSuppressTrailingZeroes
  ToleranceSuppressZeroFeet
  ToleranceSuppressZeroInches
  ToleranceUpperLimit
  TrueColor
  UnitsFormat
  VerticalTextPosition
  Visible

© Bricsys NV. All rights reserved.