Class AcadPolygonMesh
Member of BricscadDb
The PolygonMesh object is a free-form mesh consisting of a series of connected polygon faces. It is identified as an M x N mesh where M represents the number of vertices in a row of the mesh and N represents the number of vertices in a column of the mesh. A mesh can be open or closed in either or both the M and N directions. A mesh that is closed in a given direction is considered to be continuous from the last row or column on to the first row or column.
To create a PolygonMesh object, use the Add3DMesh method. To access a PolygonMesh object, use the following methods and properties:
Methods | Properties |
---|---|
AppendVertex | Application |
ArrayPolar | Coordinate |
ArrayRectangular | Coordinates |
Copy | Document |
Delete | Handle |
Erase | HasExtensionDictionary |
Explode | Hyperlinks |
GetBoundingBox | Layer |
GetExtensionDictionary | Linetype |
GetXData | LinetypeScale |
Highlight | Lineweight |
IntersectWith | Material |
Mirror | MClose |
Mirror3D | MDensity |
Move | MVertexCount |
Rotate | Nclose |
Rotate3D | NDensity |
ScaleEntity | NVertexCount |
SetXData | Parent |
TransformBy | PlotStyleName |
Update | TrueColor |
Type | |
Visible |
© Bricsys NV. All rights reserved. |