BIMStory Class |
The BIMStory type exposes the following members.
Name | Description | |
---|---|---|
![]() |
BIMStory |
Initializes a new instance of the BIMStory class
|
![]() |
BIMStory(BIMStory) |
Initializes a new instance of the BIMStory class
|
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
Description | (Overrides BIMSpatialLocationDescription.) |
![]() |
Elevation | |
![]() |
GetTypeDesc | (Overrides BIMSpatialLocationGetTypeDesc.) |
![]() |
GetTypeName | (Overrides BIMSpatialLocationGetTypeName.) |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
Name | (Overrides BIMSpatialLocationName.) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
Name | Description | |
---|---|---|
![]() ![]() |
AllObjectStories | |
![]() ![]() |
AllStringStories | |
![]() ![]() |
AssignedStory | |
![]() |
AssignToEntity | |
![]() ![]() |
Cast | |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
CreateStory(String, BIMBuilding) | |
![]() ![]() |
CreateStory(Database, String, String) | |
![]() |
DeleteStory | |
![]() ![]() |
DeleteStory(Database, String, String) | |
![]() |
DeleteUnmanagedObject | (Inherited from BIMObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
Finalize | (Inherited from DisposableWrapper.) |
![]() |
GetAssignedObjects | |
![]() |
GetBuilding | |
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() ![]() |
GetStory | |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
HasBuilding | (Inherited from BIMSpatialLocation.) |
![]() |
HasStory | (Inherited from BIMSpatialLocation.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
IsBuilding | (Inherited from BIMSpatialLocation.) |
![]() |
IsNull | (Overrides BIMSpatialLocationIsNull.) |
![]() |
IsStory | (Inherited from BIMSpatialLocation.) |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() |
SetNull | (Overrides BIMSpatialLocationSetNull.) |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
Name | Description | |
---|---|---|
![]() ![]() |
Equality | |
![]() ![]() |
Inequality |
© Bricsys NV. All rights reserved. |