BIMSpatialLocation Class |
The BIMSpatialLocation type exposes the following members.
Name | Description | |
---|---|---|
![]() |
BIMSpatialLocation |
Initializes a new instance of the BIMSpatialLocation class
|
![]() |
BIMSpatialLocation(BIMBuilding) |
Initializes a new instance of the BIMSpatialLocation class
|
![]() |
BIMSpatialLocation(BIMSpatialLocation) |
Initializes a new instance of the BIMSpatialLocation class
|
![]() |
BIMSpatialLocation(BIMStory) |
Initializes a new instance of the BIMSpatialLocation class
|
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
Description | (Overrides BIMObjectDescription.) |
![]() |
GetTypeDesc | (Overrides BIMObjectGetTypeDesc.) |
![]() |
GetTypeName | (Overrides BIMObjectGetTypeName.) |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
Name | (Overrides BIMObjectName.) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
Name | Description | |
---|---|---|
![]() ![]() |
AssignedSpatialLocation | |
![]() |
AssignToEntity | |
![]() ![]() |
Cast | |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
DeleteUnmanagedObject | (Inherited from BIMObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
Finalize | (Inherited from DisposableWrapper.) |
![]() |
GetAssignedObjects | |
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
HasBuilding | |
![]() |
HasStory | |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
IsBuilding | |
![]() |
IsNull | (Overrides BIMObjectIsNull.) |
![]() |
IsStory | |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() ![]() |
RemoveSpatialLocationFrom | |
![]() |
SetNull | (Overrides BIMObjectSetNull.) |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
Name | Description | |
---|---|---|
![]() ![]() |
Equality | |
![]() ![]() |
Inequality |
© Bricsys NV. All rights reserved. |