Selects a cell in this table by the specified
point, viewing direction, and orientation.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual TableHitTestInfo Select(
Point3d pickingPoint,
Vector3d hitTestViewDirection,
Vector3d hitTestViewOrientation,
bool allowOutside,
bool inPickFirst,
FullSubentityPath[] paths
)
Public Overridable Function Select (
pickingPoint As Point3d,
hitTestViewDirection As Vector3d,
hitTestViewOrientation As Vector3d,
allowOutside As Boolean,
inPickFirst As Boolean,
paths As FullSubentityPath()
) As TableHitTestInfo
public:
virtual TableHitTestInfo Select(
Point3d pickingPoint,
Vector3d hitTestViewDirection,
Vector3d hitTestViewOrientation,
bool allowOutside,
bool inPickFirst,
array<FullSubentityPath>^ paths
)
abstract Select :
pickingPoint : Point3d *
hitTestViewDirection : Vector3d *
hitTestViewOrientation : Vector3d *
allowOutside : bool *
inPickFirst : bool *
paths : FullSubentityPath[] -> TableHitTestInfo
override Select :
pickingPoint : Point3d *
hitTestViewDirection : Vector3d *
hitTestViewOrientation : Vector3d *
allowOutside : bool *
inPickFirst : bool *
paths : FullSubentityPath[] -> TableHitTestInfo
Parameters
- pickingPoint Point3d
- [in] 3D picking point in WCS.
- hitTestViewDirection Vector3d
- [in] 3D vector in WCS that specifies the view direction for the
hit test.
- hitTestViewOrientation Vector3d
- [in] 3D vector in WCS that specifies the view orientation for
the hit test.
- allowOutside Boolean
- [in] Indicates whether a pick point outside the table will
select a cell.
- inPickFirst Boolean
- [in] If true, the entity is already in the pickfirst set; if
false, the pickfirst logic should attempt to sub-select the entity
directly.
- paths FullSubentityPath
- [out] Receives the full subentity paths of the selected
cells.
Return Value
TableHitTestInfo
TableHitTestInfo instance that includes information about table hit
test.
Remarks
Not
implemented.
See Also