RevolveOptionsCheckRevolveCurve Method
|
Checks whether the entity is valid for the
revolve operation.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public RevolveOptionsCheckRevolveCurveOut CheckRevolveCurve(
Entity ent,
Point3d axisPnt,
Vector3d axisDir,
bool displayErrorMessages
)
Public Function CheckRevolveCurve (
ent As Entity,
axisPnt As Point3d,
axisDir As Vector3d,
displayErrorMessages As Boolean
) As RevolveOptionsCheckRevolveCurveOut
public:
RevolveOptionsCheckRevolveCurveOut^ CheckRevolveCurve(
Entity^ ent,
Point3d axisPnt,
Vector3d axisDir,
bool displayErrorMessages
)
member CheckRevolveCurve :
ent : Entity *
axisPnt : Point3d *
axisDir : Vector3d *
displayErrorMessages : bool -> RevolveOptionsCheckRevolveCurveOut
Parameters
- ent Entity
- [in] Entity to revolve.
- axisPnt Point3d
- [in] Point on axis of revolution.
- axisDir Vector3d
- [in] Direction of axis of revolution.
- displayErrorMessages Boolean
- [in] Flag that specifies whether to display errors if there are
any.
Return Value
RevolveOptionsCheckRevolveCurveOut
RevolveOptionsCheckRevolveCurveOut object that indicates the result
of the check. It can signal the following statuses: * The revolved
entity is closed. * The revolved entity is open and whether its
endpoints lie on the axis of revolution. * The revolved entity is
planar.
See Also