BlockPropertiesTableRowCollection Class

Inheritance Hierarchy
SystemObject
  Teigha.DatabaseServicesBlockPropertiesTableRowCollection

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class BlockPropertiesTableRowCollection : ICollection, 
        IEnumerable

The BlockPropertiesTableRowCollection type exposes the following members.

Properties
  Name Description
Public property Count Property that represents the count of elements that this collection currently stores.
Public property IsSynchronized Property that indicates whether access to this collection is thread-safe.
Public property Item Property that represents an item from the collection at the specified index.
Public property SyncRoot Property that represents an object that can be used to synchronize access to this collection.
Top
Methods
  Name Description
Public method AddAt Adds a row after the specified index.
Public method AddItem Adds the specified column to the end of a table.
Public method Clear Clears the entire table.
Public method CopyTo Copies the entire collection to the array starting at the specified index.
Public method GetEnumerator Returns an enumerator that iterates through the collection.
Public method GetIndex Returns the index of the specified row within this collection.
Public method Move(BlockPropertiesTableRow, Int32) Moves this collection of table rows from the current index of the specified table row to a new index.
Public method Move(Int32, Int32) Moves this collection of table rows to a new index.
Public method Remove(BlockPropertiesTableRow) Removes the specified table row.
Public method Remove(Int32) Removes a table row from the specified index.
Public method Sort Sorts the rows from the specified column in ascending or descending order.
Top
See Also

©  Bricsys NV. All rights reserved.