GeometryPolypoint(Point3dCollection,
EntityColorCollection, TransparencyCollection,
Vector3dCollection, IntPtrCollection,
Int32) Method
|
Introduces an array of points to the
vectorization context.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public abstract bool Polypoint(
Point3dCollection points,
EntityColorCollection colors,
TransparencyCollection transparency,
Vector3dCollection normals,
IntPtrCollection subentityMarkers,
int pointSize
)
Public MustOverride Function Polypoint (
points As Point3dCollection,
colors As EntityColorCollection,
transparency As TransparencyCollection,
normals As Vector3dCollection,
subentityMarkers As IntPtrCollection,
pointSize As Integer
) As Boolean
public:
virtual bool Polypoint(
Point3dCollection^ points,
EntityColorCollection^ colors,
TransparencyCollection^ transparency,
Vector3dCollection^ normals,
IntPtrCollection^ subentityMarkers,
int pointSize
) abstract
abstract Polypoint :
points : Point3dCollection *
colors : EntityColorCollection *
transparency : TransparencyCollection *
normals : Vector3dCollection *
subentityMarkers : IntPtrCollection *
pointSize : int -> bool
Parameters
- points Point3dCollection
- [in] Array of points.
- colors EntityColorCollection
- [in] Array of colors.
- transparency TransparencyCollection
- [in] Collection of transparency values.
- normals Vector3dCollection
- [in] Array of normals.
- subentityMarkers IntPtrCollection
- [in] Array of subentity markers.
- pointSize Int32
- [in] Size of points in pixels.
Return Value
Boolean
true. This method also throws a corresponding exception if it
fails.
Remarks
The points takes
on the current color if the colors array
isn't specified. If set, length of colors, transparency, normals
and sub-entity marker arrays must have an equal count of elements
in the points array.
See Also