EdgeRef(CompoundObjectId,
SubentityId, SubentityId, Curve3d)
Constructor
|
Constructor for the EdgeRef class. Creates an
edge reference based on the specified full sub-entity path.
Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in
TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public EdgeRef(
CompoundObjectId compoundObjectId,
SubentityId edgeSubentId,
SubentityId faceSubentId,
Curve3d curve
)
Public Sub New (
compoundObjectId As CompoundObjectId,
edgeSubentId As SubentityId,
faceSubentId As SubentityId,
curve As Curve3d
)
public:
EdgeRef(
CompoundObjectId^ compoundObjectId,
SubentityId edgeSubentId,
SubentityId faceSubentId,
Curve3d^ curve
)
new :
compoundObjectId : CompoundObjectId *
edgeSubentId : SubentityId *
faceSubentId : SubentityId *
curve : Curve3d -> EdgeRef
Parameters
- compoundObjectId CompoundObjectId
- [in] Identifier of the compound object that is the base of this
edge reference.
- edgeSubentId SubentityId
- [in] Edge sub-entity.
- faceSubentId SubentityId
- [in] Face sub-entity.
- curve Curve3d
- [in] Curve that is the base of this edge reference.
See Also