Edge
|
This .NET class wraps the OdDbEdgeRef class.
This class represents a reference to an edge.
The EdgeRef type exposes the following members.
Name | Description | |
---|---|---|
![]() |
EdgeRef | Default constructor for the EdgeRef class. Creates an object that wraps a corresponding C++ OdDbEdgeRef object. |
![]() |
EdgeRef(CompoundObjectId) | Constructor for the EdgeRef class. Creates an edge reference based on the specified compound object. |
![]() |
EdgeRef(Curve3d) | Constructor for the EdgeRef class. Creates an edge reference based on the specified curve. |
![]() |
EdgeRef(Entity) | Constructor for the EdgeRef class. Creates an edge reference based on the specified entity. |
![]() |
EdgeRef(FullSubentityPath) | Constructor for the EdgeRef class. Creates an edge reference based on the specified full sub-entity path. |
![]() |
EdgeRef(CompoundObjectId, SubentityId) | Constructor for the EdgeRef class. Creates an edge reference based on the specified compound object. |
![]() |
EdgeRef(CompoundObjectId, SubentityId, SubentityId) | Constructor for the EdgeRef class. Creates an edge reference based on the specified full sub-entity path. |
![]() |
EdgeRef(CompoundObjectId, SubentityId, SubentityId, Curve3d) | Constructor for the EdgeRef class. Creates an edge reference based on the specified full sub-entity path. |
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
Curve | |
![]() |
Entity | (Inherited from SubentRef) |
![]() |
FaceSubentity | |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
IsEmpty | (Inherited from GeomRef) |
![]() |
IsValid | (Inherited from GeomRef) |
![]() |
SubentId | (Inherited from SubentRef) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
Name | Description | |
---|---|---|
![]() |
Clone | (Inherited from RXObject) |
![]() |
CompareTo | (Inherited from RXObject) |
![]() |
CopyFrom(RXObject) | (Inherited from RXObject) |
![]() |
CopyFrom(SubentRef) | Copies the contents of the specified object into the messaged
object. (Inherited from SubentRef) |
![]() |
CreateEntity | Creates an entity from this sub-entity reference. (Inherited from SubentRef) |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
DeleteUnmanagedObject | (Inherited from RXObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
Finalize | (Inherited from DisposableWrapper) |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetRXClass | (Inherited from RXObject) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject
object. (Inherited from MarshalByRefObject) |
![]() |
QueryX | (Inherited from RXObject) |
![]() |
Reset | Resets the contents of the geometry reference to empty. (Inherited from GeomRef) |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
![]() |
X | (Inherited from RXObject) |
© Bricsys NV. All rights reserved. |