EdgeRef Constructor

Overload List
  Name Description
Public method EdgeRef Default constructor for the EdgeRef class. Creates an object that wraps a corresponding C++ OdDbEdgeRef object.
Public method EdgeRef(CompoundObjectId) Constructor for the EdgeRef class. Creates an edge reference based on the specified compound object.
Public method EdgeRef(Curve3d) Constructor for the EdgeRef class. Creates an edge reference based on the specified curve.
Public method EdgeRef(Entity) Constructor for the EdgeRef class. Creates an edge reference based on the specified entity.
Public method EdgeRef(FullSubentityPath) Constructor for the EdgeRef class. Creates an edge reference based on the specified full sub-entity path.
Public method EdgeRef(CompoundObjectId, SubentityId) Constructor for the EdgeRef class. Creates an edge reference based on the specified compound object.
Public method EdgeRef(CompoundObjectId, SubentityId, SubentityId) Constructor for the EdgeRef class. Creates an edge reference based on the specified full sub-entity path.
Public method EdgeRef(CompoundObjectId, SubentityId, SubentityId, Curve3d) Constructor for the EdgeRef class. Creates an edge reference based on the specified full sub-entity path.
Top
See Also