DynamicDimensionData Class

This class represents dynamic dimensions which are temporary Dimension objects. These objects can be invoked and displayed when new database entities or grip-editing database-resident entities are created.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesDynamicDimensionData

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class DynamicDimensionData : DisposableWrapper

The DynamicDimensionData type exposes the following members.

Constructors
  Name Description
Public method DynamicDimensionData Default constructor for the DynamicDimensionData class.
Public method DynamicDimensionData(Dimension) Constructor for the DynamicDimensionData class. Creates dynamic dimension data from the specified dimension.
Public method DynamicDimensionData(Dimension, Boolean) Constructor for the DynamicDimensionData class. Creates dynamic dimension data from the specified dimension.
Public method DynamicDimensionData(Dimension, Boolean, Boolean) Constructor for the DynamicDimensionData class. Creates dynamic dimension data from the specified dimension.
Top
Properties
  Name Description
Public property ApplicationData Property that represents the application-specific data associated with this object.
Public property Dimension Property that represents the dimension object.
Public property Editable Property that indicates whether this dynamic dimension is editable.
Public property Focal Property that indicates whether the current focus dynamic dimension is true.
Public property HideIfValueIsZero Property that indicates whether this dimension should be hidden if its value is zero.
Public property Visible Property that indicates whether this dimension is invisible.
Top
Methods
  Name Description
Public methodStatic member Create Creates a DynamicDimensionData object based on the passed pointer.
Top
See Also

©  Bricsys NV. All rights reserved.