Solid3dCreateRevolvedSolid(Entity,
SubentityId, Point3d, Vector3d, Double,
Double, RevolveOptions) Method
|
Creates a solid by revolving a face about the
axis of revolution.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void CreateRevolvedSolid(
Entity profileEntity,
SubentityId faceSubEntityId,
Point3d axisPoint,
Vector3d axisDir,
double angleOfRevolution,
double startAngle,
RevolveOptions revolveOptions
)
Public Overridable Sub CreateRevolvedSolid (
profileEntity As Entity,
faceSubEntityId As SubentityId,
axisPoint As Point3d,
axisDir As Vector3d,
angleOfRevolution As Double,
startAngle As Double,
revolveOptions As RevolveOptions
)
public:
virtual void CreateRevolvedSolid(
Entity^ profileEntity,
SubentityId faceSubEntityId,
Point3d axisPoint,
Vector3d axisDir,
double angleOfRevolution,
double startAngle,
RevolveOptions^ revolveOptions
)
abstract CreateRevolvedSolid :
profileEntity : Entity *
faceSubEntityId : SubentityId *
axisPoint : Point3d *
axisDir : Vector3d *
angleOfRevolution : float *
startAngle : float *
revolveOptions : RevolveOptions -> unit
override CreateRevolvedSolid :
profileEntity : Entity *
faceSubEntityId : SubentityId *
axisPoint : Point3d *
axisDir : Vector3d *
angleOfRevolution : float *
startAngle : float *
revolveOptions : RevolveOptions -> unit
Parameters
- profileEntity Entity
- [in] Entity containing the face for revolving.
- faceSubEntityId SubentityId
- [in] Face's subentity ID.
- axisPoint Point3d
- [in] Point on the axis of revolution.
- axisDir Vector3d
- [in] Direction of the revolution axis.
- angleOfRevolution Double
- [in] Revolution angle in radians.
- startAngle Double
- [in] Start angle of rotation. If 0, rotation starts from the
current position of revolved entity.
- revolveOptions RevolveOptions
- [in] Revolve options.
Remarks
Entity for
revolving must be a valid planar curve, region, or planar surface.
This method is implemented only for the Spatial modeler.
See Also