SubentityOverruleGetGripPointsAtSubentPath
Method
|
Overrules the
Entity.subGetGripPointsAtSubentPath() method and calls it in the
default implementation.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void GetGripPointsAtSubentPath(
Entity entity,
FullSubentityPath subPath,
GripDataCollection grips,
double curViewUnitSize,
int gripSize,
Vector3d curViewDir,
GetGripPointsFlags bitFlags
)
Public Overridable Sub GetGripPointsAtSubentPath (
entity As Entity,
subPath As FullSubentityPath,
grips As GripDataCollection,
curViewUnitSize As Double,
gripSize As Integer,
curViewDir As Vector3d,
bitFlags As GetGripPointsFlags
)
public:
virtual void GetGripPointsAtSubentPath(
Entity^ entity,
FullSubentityPath subPath,
GripDataCollection^ grips,
double curViewUnitSize,
int gripSize,
Vector3d curViewDir,
GetGripPointsFlags bitFlags
)
abstract GetGripPointsAtSubentPath :
entity : Entity *
subPath : FullSubentityPath *
grips : GripDataCollection *
curViewUnitSize : float *
gripSize : int *
curViewDir : Vector3d *
bitFlags : GetGripPointsFlags -> unit
override GetGripPointsAtSubentPath :
entity : Entity *
subPath : FullSubentityPath *
grips : GripDataCollection *
curViewUnitSize : float *
gripSize : int *
curViewDir : Vector3d *
bitFlags : GetGripPointsFlags -> unit
Parameters
- entity Entity
- [in] Entity.
- subPath FullSubentityPath
- [in] Full subentity path object identifying the subentity.
- grips GripDataCollection
- [in] Grip data objects.
- curViewUnitSize Double
- [in] Size of one drawing unit in the current viewport (in
pixels).
- gripSize Int32
- [in] Size of the current grip point (in pixels).
- curViewDir Vector3d
- [in] Vector that specifies the view direction in the current
viewport.
- bitFlags GetGripPointsFlags
- [in] Mask of one or more flags specified by the
GetGripPointsFlags enumeration.
See Also