OsnapOverruleGetObjectSnapPoints(Entity,
ObjectSnapModes, IntPtr, Point3d,
Point3d, Matrix3d, Point3dCollection,
IntegerCollection) Method
|
Calls the corresponding
OdDbOsnapOverrule::getOsnapPoints() method.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void GetObjectSnapPoints(
Entity entity,
ObjectSnapModes snapMode,
IntPtr gsSelectionMark,
Point3d pickPoint,
Point3d lastPoint,
Matrix3d viewTransform,
Point3dCollection snapPoints,
IntegerCollection geometryIds
)
Public Overridable Sub GetObjectSnapPoints (
entity As Entity,
snapMode As ObjectSnapModes,
gsSelectionMark As IntPtr,
pickPoint As Point3d,
lastPoint As Point3d,
viewTransform As Matrix3d,
snapPoints As Point3dCollection,
geometryIds As IntegerCollection
)
public:
virtual void GetObjectSnapPoints(
Entity^ entity,
ObjectSnapModes snapMode,
IntPtr gsSelectionMark,
Point3d pickPoint,
Point3d lastPoint,
Matrix3d viewTransform,
Point3dCollection^ snapPoints,
IntegerCollection^ geometryIds
)
abstract GetObjectSnapPoints :
entity : Entity *
snapMode : ObjectSnapModes *
gsSelectionMark : IntPtr *
pickPoint : Point3d *
lastPoint : Point3d *
viewTransform : Matrix3d *
snapPoints : Point3dCollection *
geometryIds : IntegerCollection -> unit
override GetObjectSnapPoints :
entity : Entity *
snapMode : ObjectSnapModes *
gsSelectionMark : IntPtr *
pickPoint : Point3d *
lastPoint : Point3d *
viewTransform : Matrix3d *
snapPoints : Point3dCollection *
geometryIds : IntegerCollection -> unit
Parameters
- entity Entity
- [in] Entity.
- snapMode ObjectSnapModes
- [in] Osnap mode to be requested.
- gsSelectionMark IntPtr
- [in] GS marker of the subentity involved in the snap
operation.
- pickPoint Point3d
- [in] WCS coordinates of the point picked during the snap
operation.
- lastPoint Point3d
- [in] WCS coordinates of the point selected just before
pickPoint.
- viewTransform Matrix3d
- [in] A transformation matrix to transform from WCS to DCS.
- snapPoints Point3dCollection
- [in] An existing array to append osnap points.
- geometryIds IntegerCollection
- [in] Reserved for future use.
See Also