OsnapOverrule Class

This class overrules a subset of object snapping linked operations that an entity specifies. It is used as a base class for classes derived from an entity to change their behavior. Each default implementation calls the corresponding method of the target class.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.RuntimeOverrule
          Teigha.DatabaseServicesOsnapOverrule

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class OsnapOverrule : Overrule

The OsnapOverrule type exposes the following members.

Constructors
  Name Description
Protected method OsnapOverrule Initializes a new instance of the OsnapOverrule class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public method GetObjectSnapPoints(Entity, ObjectSnapModes, IntPtr, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection) Calls the corresponding OdDbOsnapOverrule::getOsnapPoints() method.
Public method GetObjectSnapPoints(Entity, ObjectSnapModes, IntPtr, Point3d, Point3d, Matrix3d, Point3dCollection, IntegerCollection, Matrix3d) Calls the corresponding OdDbOsnapOverrule::getOsnapPoints() method.
Public method IsContentSnappable Checks whether the entity is a block entity that requires investigation of the block definition.
Public method SetCustomFilter Enables usage of the IsApplicable method to check whether an overrule is applied.
(Overrides OverruleSetCustomFilter)
Public method SetExtensionDictionaryEntryFilter Enables usage of an extension dictionary lookup for checking whether an overrule is applied.
(Overrides OverruleSetExtensionDictionaryEntryFilter(String))
Public method SetIdFilter Enables usage of ID lookups for checking whether an overrule is applied.
(Overrides OverruleSetIdFilter(ObjectId))
Public method SetNoFilter Disables the filter methods (SetCustomFilter, SetExtensionDictionaryEntryFilter, SetIdFilter, SetXDataFilter) and the IsApplicable() method for checking whether an overrule is applied.
(Overrides OverruleSetNoFilter)
Public method SetXDataFilter Enables the usage of xdata for checking whether an overrule is applied.
(Overrides OverruleSetXDataFilter(String))
Top
See Also

©  Bricsys NV. All rights reserved.