LayerViewportProperties Class

This class defines properties of the layer viewports that are used in LayerTableRecord.
Inheritance Hierarchy
SystemObject
  Teigha.DatabaseServicesLayerViewportProperties

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class LayerViewportProperties

The LayerViewportProperties type exposes the following members.

Properties
  Name Description
Public property Color Property that represents the color of the layer.
Public property IsColorOverridden Property that indicates whether the color is overridden for the associated layer and viewport.
Public property IsLinetypeOverridden Property that indicates whether the linetype is overridden for the associated layer and viewport.
Public property IsLineWeightOverridden Property that indicates whether the lineweight is overridden for the associated layer and viewport.
Public property IsPlotStyleOverridden Property that indicates whether the plot style is overridden for the associated layer and viewport.
Public property IsTransparencyOverridden Property that indicates whether the transparency is overridden for the associated layer and viewport.
Public property LinetypeObjectId Property that represents the object ID of the layer in the associated viewport.
Public property LineWeight Property that represents the lineweight of the layer in the associated viewport.
Public property PlotStyleName Property that represents the plot style name.
Public property PlotStyleNameId Property that represents the plot style name object ID.
Top
Methods
  Name Description
Public method RemoveOverrides Removes all overrides associated with the layer and viewport.
Top
See Also

©  Bricsys NV. All rights reserved.