GeometryOverrule Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.RuntimeOverrule
          Teigha.DatabaseServicesGeometryOverrule

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class GeometryOverrule : Overrule

The GeometryOverrule type exposes the following members.

Constructors
  Name Description
Protected method GeometryOverrule Initializes a new instance of the GeometryOverrule class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public method GetGeomExtents  
Public method IntersectWith(Entity, Entity, Intersect, Point3dCollection, IntPtr, IntPtr)  
Public method IntersectWith(Entity, Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr)  
Public method SetCustomFilter
(Overrides OverruleSetCustomFilter)
Public method SetExtensionDictionaryEntryFilter
(Overrides OverruleSetExtensionDictionaryEntryFilter(String))
Public method SetIdFilter
(Overrides OverruleSetIdFilter(ObjectId))
Public method SetNoFilter
(Overrides OverruleSetNoFilter)
Public method SetXDataFilter
(Overrides OverruleSetXDataFilter(String))
Top
See Also

©  Bricsys NV. All rights reserved.