FaceStyle Class

This class wraps the OdGiFaceStyle class which defines a set of visual style properties that can be applied to the faces of graphical entities. For more information, see Working with Visual Styles.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceFaceStyle

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class FaceStyle : RXObject, 
        ICloneable

The FaceStyle type exposes the following members.

Constructors
  Name Description
Public method FaceStyle Default constructor for the FaceStyle class.
Top
Properties
  Name Description
Public property FaceColorMode Property that represents a color mode for faces.
Public property FaceModifiers Property that represents face modifiers for a face style.
Public property LightingModel Property that represents a lighting model for faces.
Public property LightingQuality Property that represents a lighting quality for faces.
Public property MonoColor Property that represents a monochromatic color for the FaceColorMode.Mono color mode.
Public property Opacity Property that represents the opacity level for faces.
Public property SpecularHighlight Property that represents the specular amount for faces. High values represent sharper results.
Top
Methods
  Name Description
Public method Clone Clones the current face style and returns a handle to the cloned object.
Public method Set Sets a face style from the passed FaceStyle object.
Top
See Also

©  Bricsys NV. All rights reserved.