TableSelectSubRegion Method
|
Selects a set of cells in this table by the
specified window box, viewing direction, and orientation.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual CellRange SelectSubRegion(
Point3d cornerPoint1,
Point3d cornerPoint2,
Vector3d selectionViewDirection,
Vector3d hitTestViewDirection,
SelectType selectionType,
bool includeCurrentSelection,
bool inPickFirst,
FullSubentityPath[] paths
)
Public Overridable Function SelectSubRegion (
cornerPoint1 As Point3d,
cornerPoint2 As Point3d,
selectionViewDirection As Vector3d,
hitTestViewDirection As Vector3d,
selectionType As SelectType,
includeCurrentSelection As Boolean,
inPickFirst As Boolean,
paths As FullSubentityPath()
) As CellRange
public:
virtual CellRange^ SelectSubRegion(
Point3d cornerPoint1,
Point3d cornerPoint2,
Vector3d selectionViewDirection,
Vector3d hitTestViewDirection,
SelectType selectionType,
bool includeCurrentSelection,
bool inPickFirst,
array<FullSubentityPath>^ paths
)
abstract SelectSubRegion :
cornerPoint1 : Point3d *
cornerPoint2 : Point3d *
selectionViewDirection : Vector3d *
hitTestViewDirection : Vector3d *
selectionType : SelectType *
includeCurrentSelection : bool *
inPickFirst : bool *
paths : FullSubentityPath[] -> CellRange
override SelectSubRegion :
cornerPoint1 : Point3d *
cornerPoint2 : Point3d *
selectionViewDirection : Vector3d *
hitTestViewDirection : Vector3d *
selectionType : SelectType *
includeCurrentSelection : bool *
inPickFirst : bool *
paths : FullSubentityPath[] -> CellRange
Parameters
- cornerPoint1 Point3d
- [in] 3D picking point in WCS that specifies the first corner
point of the window box selection.
- cornerPoint2 Point3d
- [in] 3D picking point in WCS that specifies the second corner
point of the window box selection.
- selectionViewDirection Vector3d
- [in] 3D vector in WCS that specifies the view direction for the
selection.
- hitTestViewDirection Vector3d
- [in] 3D vector in WCS that specifies the view orientation for
the hit test.
- selectionType SelectType
- [in] Selection type.
- includeCurrentSelection Boolean
- [in] Indicates whether the selected cells include currently
selected cells and newly selected cells or only newly selected
cells.
- inPickFirst Boolean
- [in] If true, the entity is already in the pickfirst set; if
false, the pickfirst logic should attempt to sub-select the entity
directly.
- paths FullSubentityPath
- [out] Receives the full subentity paths of the selected
cells.
Return Value
CellRange
Remarks
Not
implemented.
See Also