VertexRef Constructor

Overload List
  Name Description
Public method VertexRef Default constructor for the VertexRef class. Creates an object that wraps a corresponding C++ OdDbVertexRef object.
Public method VertexRef(CompoundObjectId) Constructor for the VertexRef class. Creates a vertex reference to an object specified by the full sub-entity path.
Public method VertexRef(Entity) Constructor for the VertexRef class. Creates a vertex reference to a specified entity.
Public method VertexRef(FullSubentityPath) Constructor for the VertexRef class. Creates a vertex reference to an object specified by the full sub-entity path.
Public method VertexRef(Point3d) Copy constructor for the VertexRef class. Creates a vertex reference to a specified point.
Public method VertexRef(CompoundObjectId, SubentityId) Constructor for the VertexRef class. Creates a vertex reference based on the specified compound object.
Public method VertexRef(CompoundObjectId, SubentityId, Point3d) Constructor for the VertexRef class. Creates a vertex reference based on the specified compound object.
Top
See Also