DrawableOverrule Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.RuntimeOverrule
          Teigha.GraphicsInterfaceDrawableOverrule

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class DrawableOverrule : Overrule

The DrawableOverrule type exposes the following members.

Constructors
  Name Description
Protected method DrawableOverrule Initializes a new instance of the DrawableOverrule class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public method RegenSupportFlags Overrules the Drawable.RegenSupportFlags method.
Public method SetAttributes Overrules the Drawable.SetAttributes method. The default implementation of this method calls the Drawable.setAttributes method.
Public method SetCustomFilter
(Overrides OverruleSetCustomFilter)
Public method SetExtensionDictionaryEntryFilter
(Overrides OverruleSetExtensionDictionaryEntryFilter(String))
Public method SetIdFilter
(Overrides OverruleSetIdFilter(ObjectId))
Public method SetNoFilter
(Overrides OverruleSetNoFilter)
Public method SetXDataFilter
(Overrides OverruleSetXDataFilter(String))
Public method ViewportDraw Overrules the Drawable.ViewportDraw method. The default implementation of this method calls the Drawable.ViewportDraw method.
Public method ViewportDrawLogicalFlags Overrules the Drawable.ViewportDrawLogicalFlags method. The default implementation of this method calls the Drawable.ViewportDrawLogicalFlags method.
Public method WorldDraw Overrules the Drawable.WorldDraw method. The default implementation of this method calls the Drawable.WorldDraw method.
Top
See Also

©  Bricsys NV. All rights reserved.